Opensuse 15 – present libldb1 mismatch with sssd and samba in the Update repository

I updated packages on one of my servers today to the latest versions available in SUSE's Update repository for Leap 15. Unfortunately this ended with errors whilst starting the sssd-service:

sssd[9042]: ldb: failed to initialise module /usr/lib64/ldb/samba/acl.so : Unavailable

In addition a module mismatch was indicated. After some analysis I found that version 1.2.3.-lp150.7.2 of the required library "libldb1" (of the Update repository) does not work together with the latest versions of sss and samba.

Use "libldb1" version 1.2.3.-lp150.2.3.1 instead (until the SuSE people correct this glitch)!